RizkyLab

A blogging framework for hackers.

Cara Filter Dan Blokir Web Porn Menggunakan Proxy Mikrotik

Selamat pagi eperibadeeehhh… Aku gak bisa tidur nih, jadi ngeluangkan sedikit tips kacangan buat yang belum tau aja. Disini kita akan berbagi cara untuk memblokir situs-situs terlarang yang mengandung unsur Pornografi, sara, judi dan lain sebagainya menggunakan fasilitas web proxy mikrotik. Untuk tutorial ini kita menggunakan OpenDNS sebagai server dns utama anda di mikrotik.

Langkah pertama gunakan OpenDNS pada Mikrotik kita.

208.67.222.123

208.67.220.123

DNS Server DNS Server

Selanjutkan kita aktifkan web proxy di mikrotik dengan perintah sebagai berikut :

/ip proxy set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \ cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=\ 600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \ parent-proxy-port=0 port=8080 serialize-connections=no src-address=0.0.0.0

/ip proxy access add action=deny disabled=no dst-host=www.youporn.com

Perintah di atas di gunakan untuk mengaktifkan web proxy mikrotik kita dan melakukan blokir akses website yo*porn[dot]com sebagai sampel website yang mengandung unsur pornografi. Anda bisa menyesuaikan website yang ingin anda filter.

Sekarang kita mensetting NAT untuk mengarahkan lalu lintas pengguna ke proxy lokal.

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp \ to-ports=8080

NAT NAT

Setelah semua tahan di atas selesai, anda bisa memaksa user untuk menggunakan spesifik DNS Server yang anda gunakan di mikrotik.

web-proxy-4

Baiklah sekarang silahkan anda bisa memanipulasi halaman error ketika pengguna melakukan akses ke situs pornografi yang anda blok. Untuk menggunakannya, anda bisa download di link berikut :

download-now

Masukan file error.htm tersebut ke dalam directori /webproxy pada mikrotik kita.

Maka ketika user melakukan akses ke situs pornografi, maka akan melihat penampakan seperti gambar di bawah ini. hasil filter

Semoga tip web proxy Mikrotik ini bisa bermanfaat. trimakasih